Original Question/Issue:
Split log file C:/xampp/apache/logs/ssl_request.log by day.
Environment:
- Product - FileCloud
- Version - ALL
- Platform - Windows
- Application - Apache
Steps to Reproduce:
By default.
Error/Log Message:
The size of ssl_request.log file get big with time.
Cause:
Since all HTTPS requests are logged in ssl_request.log, the size of the file get big with time.
Resolution/Workaround:
- Backup C:\xampp\apache\conf\extra\httpd-ssl.conf
- Edit httpd-ssl.conf as below:
________________________
# Per-Server Logging:
# The home of a custom SSL log file. Use this when you want a
# compact non-error SSL logfile on a virtual host basis.
#CustomLog "/xampp/apache/logs/ssl_request.log" \
# "%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"
CustomLog "|bin/rotatelogs.exe -l C:/xampp/apache/logs/ssl_request.%Y.%m.%d.log 86400" \
"%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"
</VirtualHost>
________________________
- Restart the Apache web server from FileCloud Control Panel.
Notes:
Depending on your FileCloud deployment the xampp directory can be found on a different system hard drive than C:\