There was a problem loading the comments.

Apache IP restrictions not working

Support Portal  »  Knowledgebase  »  Viewing Article

  Print

Original Question

or Issue:

Trying to configure IP Restrictions to the admin portal

Environment:

  • Product - FileCloud Server
  • Version - 23.241.X
  • Platform - Windows
Steps to Reproduce:

 

 

Error or Log Message:  

Defect or

Enhancement Number:

 
Cause:

In the ssl_request logs, we see all connections are coming from a single IP

Issue was a load balancer in front of the FileCloud server.

Have to account for the load balancer IP when doing IP restrictions, since the FileCloud server sees everything coming from one IP.

Resolution or

Workaround:

After editing C:\xampp\apache\conf\extra\httpd-filecloud.conf

 

      <Location /ui/admin2>
                Order deny,allow
                deny from all
                allow from X.
                allow from X.X
      </Location>

 

IPs will still not be restricted due to the load balancer in front of the FileCloud server

Notes:  Restricting Access To Admin UI Based On IP Addresses - FileCloud Docs - Server

Share via

Related Articles


Self-Hosted Help Desk Software by SupportPal
© FileCloud