Original Question/Issue:
SSO Login not working with Teams integration
Environment:
Product - FileCloud Server or Online
Version - Any
Platform - On-premise or Online
Application - MS Teams
Steps to Reproduce:
After enabling MS Team integration in Microsoft side and FileCloud Admin panel, try to login to FileCloud using the MS teams app and from chat window using "Login with SSO" option in FileCloud page.
Error/Log Message:
Clicking on "Login with SSO" will show a blank page.
Cause:
Issue can happen due to multiple changes that are required in FileCloud Server, MS Teams developer portal and MS Teams app in client side.
Resolution/Workaround:
Change 1:
SSO login require settings edited in the saml config.php file located under the below path:
Windows: xampp\htdocs\thirdparty\simplesaml\config\config.php
Linux: /var/www/html/thirdparty/simplesaml/config/config.php
The file needs to have the values as following:
'session.cookie.secure' => true,
'session.cookie.samesite' => 'None',
Change 2:
Make sure the "Valid Domains" section has FileCloud URL ie subdomain.domain.tld, *.domain.tld, login.microsoftonline.com and sts.windows.net, refer to the screenshot. If you this change was made after publishing the app once, the app version needs to be changed and app should be published again.
Change 3:
Clear all cached sessions from teams by following below steps:
Close all teams services (task manager)
Clear Teams Cache - Link here
Clear contents from the below paths:
C:\Users\username\AppData\Local\Packages\MSTeams_8wekyb3d8bbwe
C:\Users\username\AppData\Local\Packages\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy
C:\Users\username\AppData\Local\Microsoft\TokenBroker
C:\Users\username\AppData\Local\Microsoft\OneAuth
This will result in user having to re-authenticate all Microsoft sessions as the cached tokens will be erased.