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Bulk Delete Disabled Accounts

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Original Question

or Issue:

How can we bulk delete all disabled FileCloud user accounts?

Environment:

  • Product - Admin Workflow
  • Version - 23.241
  • Platform - All
Steps to Reproduce:

 

Error or Log Message:

 

Defect or

Enhancement Number:

 
Cause:

There are too many disabled user accounts that need to be deleted automatically.

Resolution or

Workaround:

 

- Connect to FileCloud Admin Portal > Workflows.
  
- Click on Add Workflow.
   

- Select if a user's last login is older than with the below parameters:
{"last_login_days_ago":-1,"user_account_type":"USER_ACCOUNT_DISABLED","day_interval":1}
   

- Click Next and select Delete user account with the below parameters:

{"comma_separated_email_id":"administrator@email.domain","donot_email_user":1}

   

- Name and save the workflow.


- Do not enable the workflow. Instead, run it manually.

 

Notes:  Use this with care! This workflow will delete all disabled user accounts and their data regardless of their last login date.


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