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Original Question
or Issue:
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Environment:
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- Product - FileCloud Server
- Version - Any
- Platform - Any
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Steps to Reproduce: |
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Error or Log Message: |
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Defect or
Enhancement Number:
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Cause: |
Below are possible causes of users not getting imported from the Active Directory server.
- Active Directory Authentication settings have not been configured from the Admin Portal
- The FileCloud Server is unable to connect to the Active Directory server
- If the Use SSL and Use TLS connection is enabled from the Admin Portal but an SSL certificate was not installed in the Active Directory Server
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Resolution or
Workaround:
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The points below can be checked to troubleshoot the issue:
- Make sure that the Active Directory authentication setting from the Admin Portal >> Settings >> Authentication tab has been configured to connect to the correct Active Directory server.
- Run an AD Test from the Admin Portal >> Settings >> Authentication tab, and make sure that it returns the following:
- Validate AD Settings returns no errors.
- Can list AD groups
- Can verify user's access
- Get Email ID returns the correct email for a user.
- Install an SSL certificate on your Active Directory Server
- Make sure to create the ldap.conf file.
- Windows Location should be c:\openldap\sysconf\ldap.conf
Ubuntu Location should be /etc/ldap/ldap.conf RHEL Location should be /etc/openldap/ldap.conf
- the ldap.conf file should contain the following:
- #
# LDAP Defaults # TLS_REQCERT never
- Restart the Apache Server.
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Notes: |
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