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Original Question
or Issue:
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Solr can't be configured in FileCloud Admin portal. |
Environment:
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- Product - On-premise
- Version - 23.1.1
- Platform - Windows
- Application - Solr
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Steps to Reproduce: |
Dedicated server for Solr
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Error or Log Message: |
Content search configuration on the Admin Portal throws an error: "Unable to create configuration. Please ensure that you copy the skeleton config directory from ...." Solr error: SolrCore '<solrcore_name>' is not available due to init failure: Error loading class 'solr.XSLTResponseWriter'
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Defect or
Enhancement Number:
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Cause: |
Solr.xml misconfiguration
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Resolution or
Workaround:
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Verify if the "solr.xml" file content present under the path: C:\xampp\solr\server\solr is the same as the following file? solr.xml
If they are different, please follow the steps:
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Override the old solr.xml file by this new one that is attached to this comment.
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After, please make a copy of customer Core (the one which contains the indexed data) and move it to a different folder, leaving Solr with no cores available.
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Once the cores are not present in the folder C:\xampp\solr\server\solr the customer can restart the server and configure again the core in the admin portal, making the tokenizer upgrade and configuring OCR (if the user had it enabled previously).
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With the core configured in the admin portal, we should copy back the backup core with the data to the path C:\xampp\solr\server\solr and proceed with the following steps:
- Get the file solrconfig.xml from the new empty core configured. Should be in a path like C:\xampp\solr\server\solr\fccore\conf and replace it in the old core, that should have a path that looks like C:\xampp\solr\server\solr\backupcore\config
- Repeat the same process for the file managed-schema.xml
- After this delete the new core and rename the backup one to the same name as the other had. In the example here would be deleting "fccore" and renaming "backupcore" to "fccore".
- With the backupcore renamed and with the fixed files inside it, you can restart the Content Search service again.
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Notes: |
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