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SSO Log Out URL is not working

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Original Question

or Issue:

When setting SSO authentication and indicating a log out URL, users encounter and error page when logging out from the FileCloud Web UI.

Environment:

  • Product - FileCloud Server / FileCloud Online
  • Version - Any
  • Platform - Any
  • Application - SSO
Steps to Reproduce:

 

 

Error or Log Message:

Below is an example screenshot when using Azure Entra ID as IdP provider.

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Defect or

Enhancement Number:

 
Cause:

A flag in the FileCloud Server has not been enabled. 

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Resolution or

Workaround:

  • Make sure that the correct URL is indicated in the Admin Portal >> Settings >> SSO >> IdP Log Out URL (Optional) field. This value can be found in your SAML application.
  • Add a setting to the FileCloud config file:

    1. Open the configuration file:
      Windows: XAMPP DIRECTORY/htdocs/config/cloudconfig.php
      Linux: /var/www/config/cloudconfig.php
    2. To make the IdP Log Out URL setting effective, add:
      define("TONIDOCLOUD_SAML_SIGNED_LOGOUT", 1);

  • For FileCloud Online/GovCloud instances, contact FileCloud Support.
Notes:   

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